2021-06-08

npm update 실행시 '3 high severity vulnerabilities' 메시지

문제

% npm update

up to date, audited 241 packages in 2s

7 packages are looking for funding
  run `npm fund` for details

3 high severity vulnerabilities

To address all issues (including breaking changes), run:
  npm audit fix --force

Run `npm audit` for details.

3 high severity vulnerabilities 메시지가 표시될 때의 버전이 노드는 14.17.0 이고, npm 은 7.16.0 이었다. 내 경우에는 너무 높은 npm 버전을 사용해서 생긴 문제인 거 같았다.

해결

$ sudo npm cache clean -f
$ sudo npm install -g n
$ sudo n lts 
    installed : v14.17.0 (with npm 6.14.13)

npm 이 6.14.13 버전으로 다운그레이드되면서 npm update를 해도 더는 문제가 발생하지 않음.